VMware ESXi/vSphere + 10.13.4

Originally posted to our community forum on 18 April 2018.

Upgrade macOS 10.12 -> 10.13.4
If you’re running macOS Sierra or below and now require macOS High Sierra in order to test your projects with Xcode 9.3, you will have to go the route of first upgrading your VMs to macOS 10.13.3. There is no other alternative at this point.

A macOS 10.13.3 installer in a .zip & .iso format is accessible to all customers in the ISO datastore which is provided by MacStadium in all regions. You can either directly mount the ISO datastore as NFS share to your macOS VM and download the macOS10.13.3.zip or attach the macOS10.13.3.iso to your macOS VM as a CD/DVD drive from the ESXi management web interface.

Once the macOS 10.13.3 installer is available to your VM you will have to initiate the upgrade process via the startosinstall command from the command line in order to prevent the APFS upgrade:

sudo /path_to_macOS10.13.3_installer.app/Contents/Resources/startosinstall --converttoapfs NO --agreetolicense --applicationpath /path_to_macOS10.13.3_installer/Install\ macOS\ High\ Sierra.app

Failing to pass the --converttoapfs NO flag will result in an unbootable VM with VMware ESXi 6.5 and below. APFS and official High Sierra support has been released with VMware ESXI 6.7.

Once your VM rebooted with macOS 10.13.3 installed you’ll be able to upgrade to the latest and greatest version of macOS High Sierra 10.13.4 via the Mac App Store.

If you run into any issues during the upgrade process please let us know by opening a Support Ticket through the MacStadium Portal.

New creation of VMs
If you’re a new customer of ours or decided to rebuild your VMs with macOS High Sierra on VMware ESXi 6.5, we recommend starting with the installation of macOS 10.12 Sierra. This is needed since ESXi 6.5 does not support APFS. Preventing an APFS upgrade of your VM’s virtual disk is not possible at the moment during a new installation of macOS High Sierra. Once you formatted your VM’s virtual disk with HFS+ and successfully installed macOS 10.12 Sierra you will need to upgrade to macOS High Sierra 10.13.3 first like described above.

Update
After a bit of testing I can now confirm that the previous, macOS 10.13.3, installer works great for upgrading your VMware VMs to macOS High Sierra.

A HighSierra-10.13.3.iso file will be soon available to you in the ISO datastore like you’re already familiar with. This .iso file can be attached to the VM as a CD/DVD drive from which you can access the Install macOS High Sierra.app and upgrade your VM to macOS High Sierra, like you’re used to from Mac App Store downloads.

Another solution is to ask for an upgrade to your VMware ESXi installation to the latest 6.7. We currently do not recommend an upgrade to VMware ESXi 6.7 to all our customers since we’ve not yet been able to fully test it.

If you have further questions of any kind please let us know by opening a ticket in the MacStadium Portal.